DropBox API - REDIRECT URI | Report Bugs | Free Forums

All Wordpress Forum requests have been moved to Wordpress Support Forums

 

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
DropBox API - REDIRECT URI
January 5, 2016
9:24 pm
Avatar
Mike_2
New Member
Forum Posts: 1
Member Since:
January 5, 2016
sp_UserOfflineSmall Offline

Hi,

I've been talking to dropbox reps, and trying to get Xcloner to work with the API 2.0 and this is my Understanding so FAR, The first issue is on there end : This is the Link provided by the Xcloner Notification E-Mail:

DROPBOX: Starting communication with the DropBox server...
Authentication required. Link to Drop Box I Tried to Show but this Forum won't allow me to show you all the Info you might need........

To Start the %2F Right before home needs to be removed, The Rep Explained it's the "Sloppy" way Dropbox is handling the request...(ALSO If you DON'T remove the %2F Dropbox gives you a 500 Server Error, After you Click Allow, When You remove the %2F you get what I show below in the address bar)

So Then I Removed the %2F right before "home" in the Link and get to the Allow APP page to grant access, And when I click Allow: I get: Server Not Found

And This In the Address Bar of My Browser:

/home/******/public_html/XCloner/cloner.cron.php?auth_callback=1&oauth_token=************&uid=*********

And that's Obviusley not going to work... The **** are Edits on what MAY BE sensitive Info....

So as Far as I can tell, The Program itself isn't sending the Correct Callback URI for DropBox?

It would have to be something to the effect of //my-web-site.com/XCloner/cloner.cron.php?auth_callback=1&oauth_token=************&uid=*********, And carry out the operation after the TOKEN SWAP....

This is the Closest I've gotten to getting this working, This looks like the last thing holding this up.....

If you need anymore info let me know I'll provide what I can.

Also if this is not a BUG and I'm just messing up my Apologize, But as far as All the Trouble shooting I've done the /home/******/public_html/XCloner/cloner.cron.php?auth_callback=1&oauth_token=************&uid=********* in the address bar was kind of a give in to me.....

Mike

Forum Timezone: UTC 0

Most Users Ever Online: 867

Currently Online:
16 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tom_1: 70

mlguru: 33

Django29: 29

D: 21

Andy: 21

Marcus: 20

Member Stats:

Guest Posters: 737

Members: 41737

Moderators: 1

Admins: 1

Forum Stats:

Groups: 3

Forums: 7

Topics: 2517

Posts: 8419

Newest Members:

tvdemura.ru tvdemura.ru

Moderators: Ovidiu - Support!: 0

Administrators: XCloner! Support: 2485

Quick contact

place

Hi there, my name is Ovidiu Liuta and i support the XCloner! project
XCloner is a Joomla backup component, Wordpress backup plugin and Free website backup tool.
Contact me here!

About company

XCloner.com is a dynamic company focusing on providing backup and recovery solutions for small to medium websites.
We are based in Romania and offer 24/7 support through forums and our private ticket system for Premium users support.

© 2020 XCloner - Website Backup and Restore made simple
All Rights Reserved | Privacy Policy