Error 404: NOT FOUND! | Wordpress Support | Free Forums

Please consider registering
guest

Log In Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Error 404: NOT FOUND!
April 11, 2011
7:13 am
nat101962
Member
Forum Posts: 5
Member Since:
April 7, 2011
Offline

Hello! Laugh

 

After I restore my backup, my homepage comes up fine.  When I try to go to a previous post I get a 404 Error where the page is not found.  Do you have any idea what I'm doing wrong.

 

Thanks so much for your help!

Thanks!   Nat
April 11, 2011
10:28 am
XCloner! Support
Admin
Forum Posts: 2482
Member Since:
September 26, 2010
Offline

Most probably the permalinks urls do not work for some reason, try and check if:

 

1. .htaccess file exists and has the correct code inside for Permalinks

2. mod_rewrite is enabled and working properly for your account

 

Ovidiu

Please consider our XCloner Premium Support or making a Donation XCloner.com – Backup Made Easy!
April 11, 2011
1:07 pm
nat101962
Member
Forum Posts: 5
Member Since:
April 7, 2011
Offline

You are the man!!!!!!

 

Thank you so much!

Thanks!   Nat
April 19, 2011
2:05 pm
Kenneth
Member
Forum Posts: 9
Member Since:
April 19, 2011
Offline

I have the same problem on a WAMP server on my computer.

What is the .htaccess file supposed to look like? Mine is as below.

----------------------------------------------

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
<IfModule mod_security.c>
    SecFilterEngine Off
</IfModule>

# END WordPress

-------------------------------------

April 19, 2011
5:32 pm
XCloner! Support
Admin
Forum Posts: 2482
Member Since:
September 26, 2010
Offline

Hi Kenneth, in what directory did you install your wordpress site? If it's a subdirectory, you might need to adjust these lines so the path points to the new subdirectory:

 

RewriteBase /subdir/

RewriteRule . /subdir/index.php [L]

 

Ovidiu

Please consider our XCloner Premium Support or making a Donation XCloner.com – Backup Made Easy!
April 20, 2011
7:07 am
Kenneth
Member
Forum Posts: 9
Member Since:
April 19, 2011
Offline

Hi, thanks for your assistance.

 

I have put the Wordpress in the www directory of wamp (C:\wamp\www\sitename)

I have tried both

RewriteBase /wamp/www/sitename
RewriteRule . /wamp/www/sitename/index.php [L]

and

RewriteBase /wamp/www/

RewriteRule . /wamp/www/index.php [L]

as well as

RewriteBase /localhost/

RewriteRule . /localhost/index.php [L]

 

localhost/sitename/ works but localhost/sitename/news does not work

Not Found

The requested URL /sitename/news was not found on this server.

 

The backend is working fine.

localhost/sitename/wp-admin/profile.php

and I can edit the pages I have created previously.

 

You or any one else got any idea?

 

/Kenneth

April 20, 2011
7:23 am
XCloner! Support
Admin
Forum Posts: 2482
Member Since:
September 26, 2010
Offline

OK, try this then:

 

#RewriteBase /

RewriteRule . index.php [L]

 

this will remove the RewriteBase and also adjust the index.php to a relative current directory path!

 

Ovidiu

Please consider our XCloner Premium Support or making a Donation XCloner.com – Backup Made Easy!
April 20, 2011
7:48 am
Kenneth
Member
Forum Posts: 9
Member Since:
April 19, 2011
Offline

Thanks again for your help.

 

Unfortunately that did not wotk either.

The backend still works though.

I guess the problem is elsewhere?

April 20, 2011
8:24 am
XCloner! Support
Admin
Forum Posts: 2482
Member Since:
September 26, 2010
Offline

Try and disable then permalinks while the site is on localhost, that should fix the internal urls, you can simply enable them back when moving the site back to the new hosting!

 

Ovidiu

Please consider our XCloner Premium Support or making a Donation XCloner.com – Backup Made Easy!
April 20, 2011
1:42 pm
Kenneth
Member
Forum Posts: 9
Member Since:
April 19, 2011
Offline

Hmm, mod_rewrite was not enbled by default.

I had to modify httpd.conf in C:wampbinapacheApache2.2.17conf

I did uncomment the line

#LoadModule rewrite_module modules/mod_rewrite.so

 

and together with

 

#RewriteBase /

RewriteRule . index.php [L]

 

it works.

 

Thanks a lot for your support.

Forum Timezone: UTC 0

Most Users Ever Online: 95

Currently Online:
12 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

mlguru: 33

Django29: 23

D: 21

Andy: 21

Marcus: 20

wmike: 18

Member Stats:

Guest Posters: 737

Members: 22424

Moderators: 1

Admins: 1

Forum Stats:

Groups: 3

Forums: 7

Topics: 2421

Posts: 10540

Newest Members: Morten_1

Moderators: Ovidiu - Support!: 0

Administrators: XCloner! Support: 2482

Quick contact

place

Hi there, my name is Ovidiu Liuta and i support the XCloner! project
XCloner is a Joomla backup component, Wordpress backup plugin and Free website backup tool.
Contact me here!

About company

XCloner.com is a dynamic company focusing on providing backup and recovery solutions for small to medium websites.
We are based in Romania and offer 24/7 support through forums and our private ticket system for Premium users support.

© 2015 XCloner - Website Backup and Restore made simple
All Rights Reserved | Privacy Policy