Backups no more display local times | General Questions and Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters – maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_TopicIcon
Backups no more display local times
May 28, 2013
12:17 am
Avatar
Bob
Member
Members
Forum Posts: 14
Member Since:
May 24, 2013
sp_UserOfflineSmall Offline

Hi,

A couple of days ago, all my backups generated by cron jobs displayed accurate
local times in the files’ names.

For instance: backup_2013-05-23_04-33… (My local time is “CEST”.)

But now (since may 25th), the same backup displays: backup_2013-05-24_19-33…,
which is not my local time.

The e-mails I receive, confirming backups, are correctly timestamped however.

I think this happened after XCloner last update.

So, it looks as if XCloner now displayed the time of a foreign server.

Is there an explanation?

May 28, 2013
7:25 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

XCloner uses the php date()  to reference the backup time, please check with your hosting support to see what time is referenced on their server.

May 30, 2013
4:38 pm
Avatar
Bob
Member
Members
Forum Posts: 14
Member Since:
May 24, 2013
sp_UserOfflineSmall Offline

Hi,

I have just contacted my hosting support and the

problem doesn’t seem to be on their side.

phpinfo() indicates:

 

date/time

support


 
enabled
 
“Olson”

Timezone Database Version


 
0.system
 
Timezone

Database


 
internal
 
Default

timezone


 
UTC
 

 

Directive
 
Local Value
 
Master Value
 
date.default_latitude
 
31.7667
 
31.7667
 
date.default_longitude
 
35.2333
 
35.2333
 
date.sunrise_zenith
 
90.583333
 
90.583333
 
date.sunset_zenith
 
90.583333
 
90.583333
 
date.timezone
 
Europe/Paris
 
Europe/Paris
 

Moreover in the Files Manager (cPanel) the last modified dates and times are correct.

It is the files’ names which are incorrect.

Example:

File’s name: backup_2013-05-29_18-03_example.com-sql-nodrop.tar

Last Modified indicates: 2013.05.30 03:33

Furthermore, I noticed that this problem occurred after the latest plugin

update.

May 30, 2013
6:12 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Right, XCloner now sets by default the timezone within the common.php file within the extension/plugin folder, look for this line

 

date_default_timezone_set('America/Los_Angeles');

 

feel free to adjust it to any value you like! Ovidiu

May 30, 2013
9:39 pm
Avatar
Bob
Member
Members
Forum Posts: 14
Member Since:
May 24, 2013
sp_UserOfflineSmall Offline

Hi Ovidiu,

So, I was right! Something has changed.

But why did you change something that worked well before. You know, not
everybody lives in the United States.

Changing the line you indicate may be a solution but it’ll have to be done
again whenever there is a plugin update… and on many blogs as far as I am
concerned.

Not very convenient, unless an option is added in the XCloner dashboard.

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
Andy: 21
D: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9946
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
Vargas
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0