Cron Backup Issue | General Questions and Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters – maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_TopicIcon
Cron Backup Issue
December 6, 2012
2:40 pm
Avatar
Guest
Guests

Hi,

I'm trying to run a cron but I get by email this notification from the cron system:

Set-Cookie: auth_clone=1
Content-type: text/html

<b>Using configs/bkpbig.php as configuration file</b><br />
<b>Starting /home/x/public_html/bkp/cloner.cron.php</b><br />
<b>Starting XCloner for site x at 2012-12-06 07:57</b><br />
<b>Creating a fullbackup</b><br />
<b>Generating Backup …</b><br />
<br />
<b>Warning</b>:  array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #2 is not an array in <b>/home/x/public_html/bkp/cloner.functions.php</b> on line <b>1937</b><br />
<br />
<b>Warning</b>:  Invalid argument supplied for foreach() in <b>/home/x/public_html/bkp/cloner.functions.php</b> on line <b>1942</b><br />
<br />
<b>Warning</b>:  array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #2 is not an array in <b>/home/x/public_html/bkp/cloner.functions.php</b> on line <b>1937</b><br />
<br />
<b>Warning</b>:  Invalid argument supplied for foreach() in <b>/home/x/public_html/bkp/cloner.functions.php</b> on line <b>1942</b><br />
<br />
<b>Warning</b>:  array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #2 is not an array in <b>/home/x/public_html/bkp/cloner.functions.php</b> on line <b>1937</b><br />
<br />
<b>Warning</b>:  Invalid argument supplied for foreach() in <b>/home/x/public_html/bkp/cloner.functions.php</b> on line <b>1942</b><br />
<br />
<b>Warning</b>:  array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #2 is not an array in <b>/home/x/public_html/bkp/cloner.functions.php</b> on line <b>1937</b><br />
<br />
<b>Warning</b>:  Invalid argument supplied for foreach() in <b>/home/x/public_html/bkp/cloner.functions.php</b> on line <b>1942</b><br />

 

What's wrong?

 

In the administration/backups folder I see all the databases saved.
No archive with files.

Also, no activity on the backup location.

I've setup the ftp server but nothing.

Thanks

December 6, 2012
9:36 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

The error is related to a database issue, are you trying to backup a database your mysql user doesn't have access to?

December 7, 2012
5:56 am
Avatar
Guest
Guests

Hi,

I'm using the “master” username and password ( the main account from that /cpanel account ).

When I login to phpmyadmin with this username I get a list with all the databases from the server.

Moreover, in xcloner interface I get the list to chose and select what to backup and all the databases files ( db.sql ) are saved in /administrator/backups . But like I previously said, just the databases and no website files.

 

Thank you very much.

December 11, 2012
4:44 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Are you trying to backup an empty database? Can you post here the full cron output of your log output?

December 12, 2012
6:49 am
Avatar
Guest
Guests

Hi,

 

First of all, thank you very much for this great support and script.

 

You'are right, there was an emty database. Now there is no empty databases but I have ohter issue 🙁

 

I get this email after the cron:

Set-Cookie: auth_clone=1

Content-type: text/html

<b>Using configs/bkpbig.php as configuration file</b><br />

<b>Starting /home/xxx/public_html/

bkp/cloner.cron.php</b><br />

<b>Starting XCloner for site 174.x.x.x at 2012-12-12 00:33</b><br />

<b>Creating a fullbackup</b><br />

<b>Generating Backup …</b><br />

And that's all…nothing more or less.
The databases are all exported and I see only 1 .tgz archive but it has only 262 Mb ( it's an incomplete archive ).
All the files and db from the server are somewhere around 4-5Gb archived and 8-9Gb unarchived.
My assumption would be that there is a limit or something.
Could you please tell me how can I check this limit and how can I change it in order to archive all the files?
Thanks again for your time.
Catalin
December 13, 2012
8:39 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Seems you are running into a timemout issue, which cron command are you using? I would advise using the php executable one and see how it goes…

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
Andy: 21
D: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9955
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
Ich Meine
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0