Dont Understand how to get a Cronjob running | General Questions and Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters – maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_TopicIcon
Dont Understand how to get a Cronjob running
September 9, 2012
4:59 pm
Avatar
Robbie8
Member
Members
Forum Posts: 9
Member Since:
September 9, 2012
sp_UserOfflineSmall Offline

Hi,

I have set up a Cron job in the XCLONER 3.1.1 product and after adding the IP address into it, the execute cron option selected from the backend administrator (settings panels) works. The Available configurations option showed –

cloner.cron.php?config=mywebsite_Cron.php

After manually running it, the following report was shown. –

Using configs/mywebsite_Cron.php as configuration file

Starting /home/mywebsite/public_html/administrator/components/com_xcloner-backupandrestore/cloner.cron.php

Starting XCloner for site http://www.mywebsite.com at 2012-09-09 17:06

Creating a fullbackup

Generating Backup …

Archive Name: XCLONER_Cron_Full_Backup.tar

Number of Files: 15481

Size of Original File: 139.32 MB

Size of Archive: 152.09 MB

Database Backup: mywebsite_mydbase: Backup Completed ( 11.91 MB )

### END REPORT

Backup Done

Backup file: /home/mywebsite/public_html/backups/XCLONER_Cron_Full_Backup.tar

Total backup size:152.09 MB

Deleting older backups than 30 days:

Deleted backup file XCLONER Backup.tar created on 2012-08-05

Notification Mail was sent to [email protected]

ALL DONE! I will exit now from cron.

.

I thought that I had to just go to my control panel and add a CRONTAB entry(so I added the entry below, which I thought would automatically run at 17:34 on every Sunday?

 

Minute Hour Day Month Weekday Command
34 17 7 * *

/home/mywebsite/public_html/administrator/components/com_xcloner-backupandrestore/configs/mywebsite_Cron.php

 

I have tried to read the WIKI, but it really does not help me in understanding how to get this to automatically run.

 

Please can you help me?

 

RobCry


September 9, 2012
8:04 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Correct cron command in your case would be

 

php /home/mywebsite/public_html/administrator/components/com_xcloner-backupandrestore/cloner.cron.php mywebsite_Cron.php
Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
Andy: 21
D: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9955
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
Ich Meine
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0