Install good - but multiple warnings on first run (Joolma 2.5) | General Questions and Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters – maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_TopicIcon
Install good – but multiple warnings on first run (Joolma 2.5)
September 14, 2012
7:49 am
Avatar
Guest
Guests

Hi

I have XCloner running on a Joomla 1.7 site (so have some experience). I downloaded version 3.1 and installed it on a Joomla 2.5 site running on Linux at GoDaddy.

The install was good – but on the first run I received all of the warnings below. Consequently, I cannot proceed. Any suggestions would be appreciated.

Thanks
Jodani

=============================================

Warning: session_start() [function.session-start]:

open(/var/chroot/home/content/19/9710819/tmp/sess_5kvn6ljrhmaak82vqm2al9m2g4,
O_RDWR) failed: No such file or directory (2) in /home/content/19/9710819/html/administrator/components/com_xcloner-backupandrestore/admin.cloner.php on line 24

Warning: session_start() [function.session-start]:
Cannot send session cookie – headers already sent by (output started at

/home/content/19/9710819/html/administrator/components/com_xcloner-backupandrestore/admin.cloner.php:24)
in /home/content/19/9710819/html/administrator/components/com_xcloner-backupandrestore/admin.cloner.php on line 24

Warning: session_start() [function.session-start]:
Cannot send session cache limiter – headers already sent (output
started at
/home/content/19/9710819/html/administrator/components/com_xcloner-backupandrestore/admin.cloner.php:24)
in /home/content/19/9710819/html/administrator/components/com_xcloner-backupandrestore/admin.cloner.php on line 24

Warning: Cannot modify header information – headers already sent
by (output started at
/home/content/19/9710819/html/administrator/components/com_xcloner-backupandrestore/admin.cloner.php:24)
in /home/content/19/9710819/html/administrator/components/com_xcloner-backupandrestore/admin.cloner.html.php on line 28

Warning: Unknown:
open(/var/chroot/home/content/19/9710819/tmp/sess_5kvn6ljrhmaak82vqm2al9m2g4,
O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

September 14, 2012
8:38 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

You will need to make the /var/chroot/home/content/19/9710819/tmp directory writeable by all users or ask your hosting support to fix this, otherwise site  php sessions won't work…

 

Ovidiu

September 14, 2012
12:43 pm
Avatar
Guest
Guests

Hi

 

Thanks for that. Managed to get GoDaddy to change the /tmp directory attributes to 707 (i.e. read, write and execute) for public and owner. However, I still get exactly the same warnings after a new install and cannot “login” in the component.

Any other ideas will be appreciated – since I have found your component to be excellent in Joomla 1.7

Do the last 2 warnings indicate that the issue may be with PHP?

Thanks
Jodani

===============

 

Warning: Unknown:
open(/var/chroot/home/content/19/9710819/tmp/sess_15fe6mfolpalgk23mbth5eoq70,
O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

September 14, 2012
1:31 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Yes, the issue is related to php, more specifically php sessions, seems to complain that this folder /var/chroot/home/content/19/9710819/tmp/ might not exist or is not accessible….

 

Ovidiu

September 15, 2012
12:10 am
Avatar
Guest
Guests

Problem solved:

GoDaddy does not create the /tmp directory above the root when Joomla is installed. They have now manually done this.

Please be aware that this problem is not a XCloner problem – but one that your hosting provider needs to solve.

 

Many thanks for the product and support.

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
Andy: 21
D: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9955
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
Ich Meine
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0