Error, warning, Error, Warning AAAAHHHHHHH | Joomla Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_TopicIcon
Error, warning, Error, Warning AAAAHHHHHHH
February 15, 2011
9:13 pm
Avatar
Martin
Member
Members
Forum Posts: 9
Member Since:
February 15, 2011
sp_UserOfflineSmall Offline

Hello,

 

i try to install my backup on a other Server. I become follow warning.

With manuel Upload.

 

Warning: is_dir() expects parameter 1 to be string, resource given in/data/multiserv/users/522016/projects/1280019/www/xxx/XCloner.php on line 2038

Warning: is_dir() expects parameter 1 to be string, resource given in/data/multiserv/users/522016/projects/1280019/www/xxx/XCloner.php on line 2038

Warning: is_dir() expects parameter 1 to be string, resource given in/data/multiserv/users/522016/projects/1280019/www/xxx/XCloner.php on line 2038

Warning: is_dir() expects parameter 1 to be string, resource given in/data/multiserv/users/522016/projects/1280019/www/xxx/XCloner.php on line 2038

 

When i try automatic Upload, i see this Error :

 

Connected to Normal ftp server www14.subdomain.com - Active Mode

Moving source file restore/XCloner.php
Warning: ftp_put() [function.ftp-put]: Could not open data connection to port 36118: Connection refused in /www/htdocs/xxxxx/xxx-xxx/administrator/components/com_xcloner-backupandrestore/cloner.functions.php on line 564
FTP upload has failed for file www/XCloner.php ! Stopping ....

 

I have no idea, what i can do.

 

Pls, help 🙁 CryCryCryCryCryCryCryCryCryCryCryCryCry

February 15, 2011
9:37 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Hi Martin!

 

1. regarding is_dir issue, make sure safe_mode is turned Off for that restore site

2. ftp upload seems to be failling(firewall issue?), so the manual transfer of the restore script and backup archive to the new location is the only solution

 

Ovidiu

February 15, 2011
9:53 pm
Avatar
Martin
Member
Members
Forum Posts: 9
Member Since:
February 15, 2011
sp_UserOfflineSmall Offline

Hello, thx for the answer.

 

to 2. that is ok. 

 

to 1. mh, where is the save mode?

on the server? in Joomla ? in xCode?

 

Thx for help.

February 15, 2011
10:08 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Any chance you could disable the open_basedir and see if it helps? If not, better extract the backup some other way and simple restart the restore process with "skip files restore" option checked

 

Ovidiu

February 15, 2011
10:16 pm
Avatar
Martin
Member
Members
Forum Posts: 9
Member Since:
February 15, 2011
sp_UserOfflineSmall Offline

Hello,

 

its run.

 LaughLaughLaughLaugh

 

I have change the option from Install files throught ftp:  - incremental transfer to Install files directly: .

 

But why can i install the backup only with this option?

 

Thx, for help

 

EDIT:

 

PLS DELETE, my two last post. With the hyperlink .

 

thank you

February 16, 2011
9:30 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

The ftp mode might fail in any of these cases:

 

1. not enough disk space, when restoring with ftp mode checked, XCloner requires more disk space, usually double the backup size

2. firewall issue

3. incorect ftp upload path

 

Ovidiu

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
D: 21
Andy: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9492
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
mherrmann89
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0