Monthly Cron Job | Old Forum | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_TopicIcon
Monthly Cron Job
May 11, 2009
12:00 am
Avatar
checkmate
Guest
Guests

Ok Completely noob here with setting up cron jobs. Is there a simple walk through for setting up a automatic monthly backup?

Trying to set it up myself but am running into a few issues/questions.

1. Says to add the cron function:
"/usr/bin/php /path_to_backup_dir/cloner.cron.php"

to the control panel crontab. Which I think I can do no problem... my question is there doesn't seem to be a cloner.cron.php file in:

"/usr/bin/php /path_to_backup_dir/cloner.cron.php"

so do I have to add it? If so what do I add? Is there an example?

Thanks,

May 11, 2009
12:00 am
Avatar
admin
Guest
Guests

The path_to_backup_dir needs to be replaced with your actual Joomla root path + "/administrator/components/com_xcloner/cloner.cron.php"

As for the monthly cronjob, you can set the time to run inside the cron software manager you are using!

Regards, Ovidiu

May 11, 2009
12:00 am
Avatar
checkmate
Guest
Guests

thanks for the reply. I had actually found that after posting.

So i setup a cron job in the crontab of my control panel with this command:

links http://www.mysite.co.....r.cron.php

And set the cron job to run on:

minute: 35
hour:12 (an hour and a half ago)
day of month: 11
month: Every month
day of week: Every day of the week

Yet in the backup folder where my manual backups show up at I didn't get a new one created...

Can you tell what I did wrong?

May 12, 2009
12:00 am
Avatar
checkmate
Guest
Guests

Im using a godaddy virtual dedicated server... looking for the cron logger... have a ticket into support about it. I tested the server time and its the correct time.

as far as using the other cron command is this correct?:

/usr/bin/php /public_html/administrator/components/com_xcloner/cloner.cron.php

Not sure if im supposed to replace the usr/bin/php with somthing?

Thanks for the quick replies.

May 12, 2009
12:00 am
Avatar
checkmate
Guest
Guests

Ok i found the cron logger:

May 11 12:35:02 ip-***-***-***-* crond[14029]: (root) CMD (links http://www.mysite.com/administrator/components/com_xcloner/cloner.cron.php)

Seems to have ran. So that must mean a problem with my xcloner settings?

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
D: 21
Andy: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9492
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
mherrmann89
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0