Automated backup under Windows gives ls errors | Report Bugs | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Automated backup under Windows gives ls errors
March 27, 2015
2:07 pm
Avatar
Nick
New Member
Members
Forum Posts: 1
Member Since:
March 27, 2015
sp_UserOfflineSmall Offline

I have had some trouble running the backup as a scheduled task under Windows due the to get_filesize function in cloner.functions.php using exec('ls'). Presumably this is due to the 2GB file size restriction on filesize(). It would be prefereable for the backup to be pure PHP possibly using one of the many alternative PHP workarounds for filesize(). The backup seems to work OK when I uncomment the original PHP version.

April 9, 2015
5:41 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

The backup should run ok despite that error message, unfortunatelly you would need to use a 64 bit version of php to overcome that error.

 

Ovidiu

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
D: 21
Andy: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9453
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
Vladimir Smitka
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0