Wordpress 2.9.2 With Xcloner = Fatal error | Report Bugs | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_TopicIcon
Wordpress 2.9.2 With Xcloner = Fatal error
December 26, 2010
9:38 pm
Avatar
Toni
Member
Members
Forum Posts: 4
Member Since:
December 26, 2010
sp_UserOfflineSmall Offline

When I Access it from the Plugins->XCloner menu, i see this error message.

 

Fatal error: Call to undefined function is_admin() in /home/a7213365/public_html/wp-content/plugins/xcloner-backup-and-restore/cloner.config.php(72) : eval()'d code on line 79

 
My Blog Is Wordpress 2.9.2

December 27, 2010
12:54 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

I think it might be caused by some code added in the wp-config.php file, try and edit the public_html/wp-content/plugins/xcloner-backup-and-restore/cloner.config.php file and remove line 72, that should fix the error

 

Regards, Ovidiu

December 27, 2010
9:59 am
Avatar
Toni
Member
Members
Forum Posts: 4
Member Since:
December 26, 2010
sp_UserOfflineSmall Offline

fix line 72, but now i get this message;

Could not connect: Host 'srv41.000webhost.com' is not allowed to connect to this MySQL serverUnable to select database DB_NAME

how to fix this, thanks.

December 27, 2010
11:30 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

SImply adjust the mysql config details in your XCloner Config area->Mysql tab.

 

Removing that line also removed the option to automatically load the mysql details in XCloner, so you need to enter them manually as above.

 

Ovidiu

December 27, 2010
12:23 pm
Avatar
Toni
Member
Members
Forum Posts: 4
Member Since:
December 26, 2010
sp_UserOfflineSmall Offline

when adjust the mysql config details in my XCloner Config area->Mysql tab. i have this error;

ERROR… Unable to write to cloner.config.php, please change the permissions!

i allready change the permissions "cloner.config.php(chmod:777)" and still have error message.

December 27, 2010
2:22 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Could you post here a screenshot from the permissions you see on this file

public_html/wp-content/plugins/xcloner-backup-and-restore/cloner.config.php

 

to recheck them? Ovidiu

December 27, 2010
7:43 pm
Avatar
Toni
Member
Members
Forum Posts: 4
Member Since:
December 26, 2010
sp_UserOfflineSmall Offline

this the screenshoot cloner.config.php

xclonerImage Enlarger

December 27, 2010
9:44 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Weird, it should work, try double checking with a normal ftp client!

I would be able to help you better if i would have direct access to that location

 

Ovidiu

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
D: 21
Andy: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9453
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
Vladimir Smitka
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0