Problems getting AMAZON S3 work. | Wordpress Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_Feed Topic RSS sp_TopicIcon
Problems getting AMAZON S3 work.
January 8, 2011
1:47 pm
Avatar
Guest
Guests

Hi,

I create an account on Amazon S3 with a bucket and folder.

I set the requered keys.

When I launch a manual cron backup, after the backup creation and at the last step a get this message:

 

"AMAZON S3: Starting communication with the Amazon S3 server...

Warning: S3::putBucket(mywebsite, private, ): [BucketAlreadyOwnedByYou] Your previous request to create the named bucket succeeded and you already own it. in /homepages/36/d123456789/htdocs/siteprod/wordpress/wp-content/plugins/xcloner-backup-and-restore/classes/S3.php on line 226
AMAZON S3: Unable to create bucket xxxxx (it may already exist and/or be owned by someone else)!"

 

If a delete de bucket and folder to let xcloner create them, I block on the message bellow and the bucket is created on S3 but not the folder I specified (the size on the backup is 175.24 KB ) :


"AMAZON S3: Starting communication with the Amazon S3 server..."

 

I use wordpress 3.0.2 and php 5.2.14 at 1and1.

 

What's wrong?

Thanks in advance

 

Thomas

January 8, 2011
2:44 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Hi Thomas! Could you try and update your wp-content/plugins/xcloner-backup-and-restore/classes/S3.php file with this latest version https://github.com/j.....ter/S3.php and see if it helps?

Beside that Warning message, do you get any other output from the cron task? Does the files transfer continues to the amazon service or it fails after that message? screenshot of the full message would help...

Check also your created bucket permissions, make sure you are allowed to add contents to it.

 

Ovidiu

January 11, 2011
2:23 am
Avatar
Guest
Guests

Hi Ovidiu,

Thanks a lot, I  was not especting a reply so quickly and I was thinking that I would have an automatic mail if someone reply, so I check the forum very later.

I
try you new file with a new bucket et folder, and It works! But when a
want to use a folder I delete one day ago, I get the message below.

 It seems that It's how amazon S3 works and this problem is specific to Europe buckets. I can load file directly in S3 from my computer in this folder. S3 support recommand to not create, delete and recreate a bucket Frown : It seems that some  methods can't see a recreated bucket during several hours (more than a day for me) ; see link http://john.keyes.ie.....u-error/  (maybe a solution?).

I will continue investigate.

I don't have any other log than this one display in the broswer:

Using configs/maincronjob.php as configuration file
Starting /homepages/36/d123456789/htdocs/siteprod/wordpress/wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php
Starting XCloner for site mywebsite.com at 2011-01-11 02:16
Creating a fullbackup
Generating Backup ...
Archive Name: backup_2011-01-11_02-16_
mywebsite.com-sql-nodrop.tar
Number of Files: 3474
Size of Original File: 184.64 MB
Size of Archive: 187.22 MB
Database Backup: db123456789: Backup Completed ( 1.78 MB )
### END REPORT
Backup Done
Backup file: /homepages/36/d123456789/htdocs/backups//backup_2011-01-11_02-16_
mywebsite.com-sql-nodrop.tar
Total backup size:187.22 MB

AMAZON S3: Starting communication with the Amazon S3 server...

Warning: S3::putBucket(mybucket, private, ): [BucketAlreadyOwnedByYou] Your previous request to create the named bucket succeeded and you already own it. in /homepages/36/d123456789/htdocs/siteprod/wordpress/wp-content/plugins/xcloner-backup-and-restore/classes/S3.php on line 226
AMAZON S3: Unable to create bucket mybucket (it may already exist and/or be owned by someone else)!

Thanks

Thomas

January 11, 2011
9:49 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

K, i have made an update in our package so XCloner checks first if the bucket exists, and if so, it continues with the upload, so what i suggest is to try this:

 

1. re-install the XCloner package

2. create a bucket manually in your Amazon account

3. try and use that bucket when specifying the XCloner upload details

 

 Let me know if it works! Ovidiu

January 11, 2011
10:14 pm
Avatar
Guest
Guests

Hi Ovidiu,

I think it is what I have already done.

I reinstall the latest version for worpress 2.1.

And update it with the S3.php you have send.

Create the bucket (in Europe) and the folder.

And I get the message above.

 

I have just deleted the bucket in Europe and I can't create the same in USA immediately.

According to Amazon S3 support forum  I have to wait up to 8-10 hours before retrying to create the same folder.

So I will try as soon as possible to create new USA located bucket and execute the cron again (I'm in France and I hope that would not cost me lot of money).

Thanks again Smile

Thomas

January 12, 2011
9:24 am
Avatar
Guest
Guests

Hi,

I create the USA-based-bucket  and try again, and I get this message at the end:

"AMAZON S3: Starting communication with the Amazon S3 server…"

I have a waiting message in the browser status bar for 2 ou 3 min and then the message "done" and nothing occurs; no backup sends to S3.

 

Regards,

Thomas

January 12, 2011
9:55 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Hmm, that usually means it waits on the file upload, however the "done" message is not being sent by the cron script if it's only that message.

 

To see if it's the current host the issue, and not amazon, try and make a cron test from a local install, so install a LAMP server on your local computer like http://www.apachefri.....mpp.html , install wordpress, then XCloner and then try the amazon upload from there with the same settings and see how it goes

 

Ovidiu

January 13, 2011
12:11 am
Avatar
Guest
Guests

Hi,

I get this in local with easyphp 5.2.10 :

AMAZON S3: Starting communication with the Amazon S3 server...

Fatal error: Call to undefined function curl_init() in C:\Program Files (x86)\EasyPHP5.2.10\www\wordpress\wp-content\plugins\xcloner-backup-and-restore\classes\S3.php on line 1294

(Any way I have in my htaccess file this line : AddType x-mapp-php5 .php )


Thomas

January 13, 2011
9:19 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

In order for the S3 option to work, you need to have php compiled with curl support

 

Ovidiu

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
D: 21
Andy: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9492
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
mherrmann89
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0