Problems with backup files | Wordpress Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters – maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_Feed Topic RSS sp_TopicIcon
Problems with backup files
November 26, 2010
8:59 pm
Avatar
D
Member
Members
Forum Posts: 21
Member Since:
November 23, 2010
sp_UserOfflineSmall Offline

1) Why are backup files the same size when they are not identical backups?
When I 'execute cron for “Full (files+database)”, “Database only”, or “Files only”, the backup file is always the same size 1.45MB.
This cannot be correct, because I did not select any files for deletion, and a Full backup, when generated manually, is 500+MB.

After executing Full backups manually, I had different size backup files then too, even though there were no changes to the site.
First Full manual backup created a file of 152.18MB, then 393.12MB, 503.02MB, 502.99MB, and 503.02MB

2) Are cron execution notifications supposed to originate from 'Cronlog JoomlaCloner'?
If so, is there a way to change name of sender?

3) Manual backup file will not download to desktop –
Download “finishes” at around 25 to 29MB without downloading full 503MB file
Then, when opening .tar download file, the following error occurs –
Unable to unarchive “backup.tar” into “Desktop” (Error 2 – No such file or directory.)

4) Why does manual backup show Full archive to be completed at much smaller size before actually being created?
When starting manual backup, I get the following screen –

Starting the manual backup process!
Database backup: xyz: Backup Completed ( 1.45 MB )

Backup /home/content/xyz/administrator/backups/backup_2010-11-26_12-00_xyz-sql-nodrop.tar created, we may continue!
Please click here to continue!

5) When is it necessary to backup Files verses Database?
If only posts have been added, then only Database needs backup?
but Files if pages and images have been added?

November 26, 2010
9:45 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

OK, to answer some of the question above:

 

1) if you are using multiple cron configs, make you re-save them with the new changes, other they will have no new effect, as for the different backup sizes, make sure that the “Include backups directory in clone:” is unchecked, if you still have issues however, feel free to open a support ticket and I will look over the issue

2) that should be fixed now, it was a legacy text from the old package

3) i would advise using a ftp client to download the backups to your desktop, the web option might be limited by your server memory limit or execution timeout

4) the full archive shown is referring to the database backup

5) usually database is the one that needs to be backed up more often, files need to be backed up when installing new plugins or adding new files to the site(images, themes, etc…)

 

Hope it helps, Ovidiu

November 27, 2010
3:05 pm
Avatar
D
Member
Members
Forum Posts: 21
Member Since:
November 23, 2010
sp_UserOfflineSmall Offline

1) I'm not using multiple cron configs, but I have saved a custom config.php file because there is no 'excute cron' link on the Cron tab unless a custom config.php file is created.

I cannot find any instructions on the purpose of a 'multiple cron config', how it is used or how to set up a multiple cron config.

I only have one cron control panel on my hosting account in which I can set up multiple “cron jobs”, but there is no way to select which files to backup. So, if I want to run separate “cron jobs” at different times and intervals, do I set up multiple cron configs for that?
And do I setup multiple configs by creating config.php files with different names so I can assign a different type of backup (Full, Files only, or Database only) to the different cron config files, thereby creating different types of auto backups?

When setting up Cron tabs at my hosting account, I had to select the script to execute the cron.
I selected the path to the custom config.php file that I had created.
Is that correct? or should I have selected a different file?

You refer to the “Include backups directory in clone”; where is that located? I don't see any such option on the Cron tab.

When selecting Cron link in left sidebar of Admin tab, the following instructions display:

For Running Multiple Crons, you need to first create a custom configuration file in the XCloner Configuration -> Cron tab and then replace “cloner.cron.php” with “cloner.cron.php?config=myconfig.php”, only use 'links' or 'lynx' options to run the cronjob
If you would like to use the php SSH command for running Multiple Crons, you will need to replace the “cloner.cron.php” with “cloner.cron.php myconfig.php” in the command line.
Notes: – if you php location is diferent than /usr/bin/php please use that one, format /$php_path/php

Replace “cloner.cron.php” where?

On the Cron tab is a text box followed by .php I replaced whatever was in that box with the name of my custom config.php file and after saving, there is nothing in that text box.
Do I have to re-enter the name of my custom config.php file every time I make changes to the Cron tab? (such as type of backup – Full, etc.)

For php SSH command, replace “cloner.cron.php” in command line where? In the custom config.php file?

What is “php location”? and how is that location determined? Are you referring to the location of custom config.php file?

2) I'm not using the “old package”. I'm using the latest download of the WP version of the plugin from XCloner website and am still getting emails from 'Cronlog JoomlaCloner'.

3) I'll have to find a workaround, but it would easier when setting XCloner up in WP for other non-tech people, to be able to instruct them on how to download backups from the XCloner admin panel than to have to instruct them on setting up and using ftp.

4) I'm trying to confirm that backup is working correctly, and it looks suspicious that all the backups created using the 'execute cron' link on the Cron tab are all the same size (including a “Full” backup), and that size (1.45MB) is also what is being displayed as the size of “Completed Backup” for a Full backup executed manually, BEFORE clicking the “continue” link, which then creates the actual backup.
How can the backup be “completed” at 1.45MB before clicking the continue link, then show up in “View Backups” as 502MB?
That is VERY confusing! What is going on here? How can I trust that backup is being properly executed when there is such conflcting information?
An auto Full backup displays as 1.45MB, while a manual Full backup initially says “completed” at 1.45MB, then the actual file shows at 502MB?
How can an auto Full backup file contain all the information at 1.45MB that a manual Full backup file does at 502MB?

5) If pages are created with templates, will the database recreate pages with templates attached, or will templates have to be manually reattached to pages?

November 27, 2010
5:35 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

I think you might have just won an award for the longest post on this forum 🙂

 

Ok, to try and answer some of your concerns:

 

1. the cron script is always located here, for wordpress: wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php , that is the script you need to setup with your cron manager, use full server path to it. Now, with multiple configs, you simply append them to the cloner.cron.php as explained in the documentation

 

2. we update the package a few hours ago

 

4. from what i understand, the 1.45 MB backup you are creating there is only a database backup, i am not sure what is the exact issue there, might be only a text miss-understanding, but the full backup message after the first step refers to the database one, you would need to click to the next step to get the files, but i am guessing you got that figured also

3. if you can increase your php.ini memory_limit and max_execution_time, that would help with the backup download from the View Backups screen, otherwise using a ftp client to simply download the backup files from your backups directory would be the same thing.

 

5. i am guessing templates are written as files on the server, if so, restoring only a database backup won't help, you still need the files 

 

  Hope it helps! We can provide better assistance through the Premium Support system including training and setup, if you need it. 

 

 Ovi

November 29, 2010
12:52 am
Avatar
D
Member
Members
Forum Posts: 21
Member Since:
November 23, 2010
sp_UserOfflineSmall Offline

1) I have created 3 custom cron config files – for Files, Database, and Full backup to local server.
I selected files, database or ‘full’, named each config descriptively, and included my IP and email address for cron log.
I have scheduled a cron job for each backup on my hosting account linked to the appropriate config file, but nothing happens.
The time for the scheduled backup passes, and I receive no cron log by email, and no backup files ever show up in the server folder.

I’m using the following paths –
wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php?config=LGSfiles.php ,
cloner.cron.php?config=LGSfull.php , and
cloner.cron.php?config=LGSdatabase.php

2) Rather than deactivate and delete, then reinstall entire plugin, can I just replace the file or files in the WP version of XCloner download
that effect the cron log email sender – ‘Cronlog JoomlaCloner’? If so, which file or files should I update?

3) Where do I look for the php.ini configuration file?
In the php.ini configuration file, how do you change or modify the code to increase the max_execution_time, and the memory_limit?
In Appendix of XCloner wiki, at section for “XCloner Limitations”, https://docs.xcloner.com/#/
there are help links for memory_limit and max_execution_time http://ro.php.net/ma…..i.core.php
but the link connects to a php manual with no explanation on how to increase memory_limit and max_execution_time for XCloner.

November 29, 2010
8:24 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

1. I would advise checking with your hosting provider to see first if their cron software runs, and second check the account cron logs

2. update the cloner.cron.php file from the package

3. a search on google will provider with multiple tutorials on how to do this, one of those is this http://drupal.org/node/207036 . Please note, to edit the main php.ini details you would need root access to the server, so better ask your hosting provider if they can do it for you

 

 Ovidiu

November 29, 2010
4:47 pm
Avatar
D
Member
Members
Forum Posts: 21
Member Since:
November 23, 2010
sp_UserOfflineSmall Offline

1)

Cron backup works fine when I use path to cloner.cron.php only ( wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php )
and do not amend with any custom config file.
I get email from my host sever confirming completion of backup, as well as from Cronlog XCloner,
and a Full backup file appears in the backups folder, that is more or less consistent in size (259.18MB)
to the manual Full backup (257.56MB).

But when I revise cron by appending with a custom config file,
( … cloner.cron.php?config=LGSdatabase.php )
I get an error message from my host –
Status: 404 Not Found
Content-type: text/html
No input file specified. – even though custom config file exists on the server.

Also, Execute Cron backup does not appear to be functioning properly from XCloner admin panel
for Files and Full backups as evidenced by the following 3 inconsistencies –
***A)***
File sizes are not consistent when added together and do not match manual backup file size –
Execute Cron Files backup + Database backup = 239.7MB;
which is 6.14MB smaller than Execute Cron Full backup, and 17.86MB smaller than Manual Full backup
Execute Cron Full backup is 11.72MB smaller than Manual Full backup
Execute Cron Database backup = 1.45MB (matches Manual Database backup)
Execute Cron Full backup = 245.84MB; Manual Full backup = 257.56MB
Execute Cron Files backup = 238.25MB
Manual Files backup = 257.73MB (which is bigger than Manual Full backup even though all tables were highlighted for deletion in backup, so backup should only consist of Files!)
***B)***
When executing separate crons for Files and Full backups, the backups never confirm completion in the browser window.
See copy of message below –
Using configs/XYZfiles.php as configuration file
Starting /home/content/xyz/wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php
Starting XCloner for site mydomain.com at 2010-11-28 08:13
Creating a files only backup
Generating Backup …
(…hangs here and never shows completion message in browser)
***C)***
Even though no completion message is given, Files and Full backups show in “View Backups” as if completed.
After downloading Cron Files and Full backups various ways (by FTP or XCloner backups panel), both the Files and Full backups can be expanded but create an error on expanding.
The expanded Files backup is then missing the Scripts folder, and there is only 1 folder and 2 files that will expand from the Full backup.

November 29, 2010
4:55 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

The first  rule when running multiple automated backups (cron), is to run them at different hours, otherwise if you run them all at the same time, the backups will be incomplete or inconsistent(so multiple crons need to run at least 1 hour difference from each other ).

 

Second, when using the multiple cron config, the correct cron command is:

 

“php /…/pathto/cloner.cron.php myconfig.php”

 

and NOT

 

“php /…/pathto/cloner.cron.php?myconfig.php”

 

I am unable to figure out what is the issue you are having there exactly, but if the cron doesn't return an output, you should contact your hosting support to see what is stopping it

 

Regards, Ovidiu

November 29, 2010
5:07 pm
Avatar
D
Member
Members
Forum Posts: 21
Member Since:
November 23, 2010
sp_UserOfflineSmall Offline

So are you saying that the text on the Cron link of the Admin tab should read –
“cloner.cron.php myconfig.php” and not “cloner.cron.php?config=myconfig.php” ?

In previous post I noted  –

When selecting Cron link in left sidebar of Admin tab, the following instructions display:

For Running Multiple Crons, you need to first create a custom
configuration file in the XCloner Configuration -> Cron tab and then
replace “cloner.cron.php” with “cloner.cron.php?config=myconfig.php”,
only use 'links' or 'lynx' options to run the cronjob

If you would like to use the php SSH command for running Multiple Crons,
you will need to replace the “cloner.cron.php” with “cloner.cron.php
myconfig.php” in the command line.

Notes: – if you php location is diferent than /usr/bin/php please use that one, format /$php_path/php

And you replied –
1. the cron script is always located here, for wordpress:
wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php , that is
the script you need to setup with your cron manager, use full server
path to it. Now, with multiple configs, you simply append them to the
cloner.cron.php as explained in the documentation

And later, I wrote –

I'm using the following paths –

wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php?config=LGSfiles.php ,

cloner.cron.php?config=LGSfull.php , and

cloner.cron.php?config=LGSdatabase.php

November 29, 2010
5:19 pm
Avatar
D
Member
Members
Forum Posts: 21
Member Since:
November 23, 2010
sp_UserOfflineSmall Offline

I am still getting error –

Status: 404 Not Found
Content-type: text/html
No input file specified.

whether using –

…/wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php?config=LGSdatabase.php”

or

…/wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php LGSdatabase.php”

(“LGSdatabase” is the name of my config file for backing up database tables only)

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
D: 21
Andy: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9668
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
jose marín
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0