WP Required sql backup directory D://administrator/backups is not writeable or does not exists! | Wordpress Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_Feed Topic RSS sp_TopicIcon
WP Required sql backup directory D://administrator/backups is not writeable or does not exists!
November 24, 2010
2:38 am
Avatar
D
Member
Members
Forum Posts: 21
Member Since:
November 23, 2010
sp_UserOfflineSmall Offline

I'm getting the following error message when I try to backup:

Required sql backup directory D://administrator/backups is not writeable or does not exists!

 

I've created a folder (DBbackups) in my WordPress 2.9.1 install, in the wp-content folder. Path is -

D://Hosting/5386477/html/wp-content/DBbackup

 

Backup start path is - D://Hosting/5386477/html/

but it keeps disappearing when I change screens and go back to Config.

 

I've also created a folder (administrator) in my root folder, and another folder (backups) inside the administrator folder,

and tried using that for my path -

D://Hosting/5386477/html/administrator/backups/

but I still get error message -

Required sql backup directory D://administrator/backups is not writeable or does not exists!

November 24, 2010
8:50 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Hi there! Could you post here a screenshot from your XCloner Config -> Info tab? Try reinstalling it first and leave the values unchanged.

Try also and replace the backup Start Path with

 

D:/Hosting/5386477/html/

 

notice the double slash is replace with a simple slash

 

Tell us also what operating system version are you using, as for the server, are you running IIS or something else?

 

Ovidiu

November 24, 2010
2:02 pm
Avatar
D
Member
Members
Forum Posts: 21
Member Since:
November 23, 2010
sp_UserOfflineSmall Offline

The info tab showed error for the path, so I corrected that and got the plugin to work.

But the exec() functionsupport is shown as Disabled, even though both 'Active' checkboxes on the General Tab are not checked.

How can exec() functionsupport be enabled?

November 24, 2010
2:11 pm
Avatar
D
Member
Members
Forum Posts: 21
Member Since:
November 23, 2010
sp_UserOfflineSmall Offline

How do you setup an automated backup in Wordpress?

November 24, 2010
2:34 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

In order to use exec, you need to check if it's allowed in your php.ini. Also, once you do that, you need to adjust the tar and mysqldump paths so they point to their .exe filenames on the server.

I would advise however you leave the Active checkboxes unchecked, XCloner will still work

 

As for automated backups, please check the XCloner Manual, we have there detailed the cronjob setup, also check the XCloner backend->Cron menu link

 

Regards, Ovidiu

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
Andy: 21
D: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9459
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
Mustafa Yildirim
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0