Problem in running Cron Job in XCloner | General Questions and Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_TopicIcon
Problem in running Cron Job in XCloner
June 20, 2014
5:49 am
Avatar
Amanda
Member
Members
Forum Posts: 3
Member Since:
June 20, 2014
sp_UserOfflineSmall Offline

Hello,

 

I have installed latest version of Xcloner i.e. 3.1.1, in my site. I have restored my site manually & successfully. 

Now, I want to run cron job for my site's automatic restore, for which I have added custom config file through Configuration > Cron > Configuration Name = mycron.php

 The problem occurs when I click on execute cron, it throws me error through navigating to

http://careertest.gu.....mycron.php

& the error says:

To run this script you need to create a custom config file inside XCloner Config, and call the script using php cli command like this:
php /home/careert/public_html/wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php mycustomconfig.php

 

After following all suggessions from topics posted like this in this forum, i have tried to remove the following code also from cloner.cron.php file, but no luck!

if(!isset($argv[1]) ) {
  echo  "<h2>".$topErrorLine1."</h2>n";
  echo "<strong>".$topErrorLine2."</strong>n";
  exit;
  }

Please note that, I have placed following commandline in my cpanel's cron tasks,

php /home/careert/public_html/wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php mycron.php

 

Hope anyone can help me out!

Any help would be appreciated!

Thank you in advance!

June 20, 2014
7:59 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

This cron command should work

 

php /home/careert/public_html/wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php mycron.php

 

what errors do you get when running it?

June 20, 2014
8:03 am
Avatar
Amanda
Member
Members
Forum Posts: 3
Member Since:
June 20, 2014
sp_UserOfflineSmall Offline

This is what i get while clicking on execute cron

 

To run this script you need to create a custom config file inside XCloner Config, and call the script using php cli command like this:
php /home/careert/public_html/wp-content/plugins/xcloner-backup-and-restore/cloner.cron.php mycustomconfig.php

June 20, 2014
8:15 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Weird, do you get the same error if you remove the top lines related to that message, that's where the script does the cli check and exists if it fails.

 

Ovidiu

June 30, 2014
9:19 am
Avatar
Amanda
Member
Members
Forum Posts: 3
Member Since:
June 20, 2014
sp_UserOfflineSmall Offline

Can you please help me to fix this cronjob issue so that I don't need to run backup manually?

Hope you can help me.

Thanks in advance!

 

Regards,

Amanda

June 30, 2014
12:52 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Yes Amanda, if you can open a support ticket and send me your site access details i will check and fix the problem you are having.

 

Ovidiu

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
D: 21
Andy: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9492
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
mherrmann89
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0