Your backup directory backups is not writeable or does not exists! | Wordpress Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters – maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_Feed Topic RSS sp_TopicIcon
Your backup directory backups is not writeable or does not exists!
November 20, 2010
5:35 pm
Avatar
Quentin
UK
Member
Members
Forum Posts: 3
Member Since:
November 20, 2010
sp_UserOfflineSmall Offline

Hi, i have just installed Xclone on a 3.1 WP installation. Installed no problem. But I am not sure how to resolve the backup path. I left the default Backup Start Path as is (which ends with: …public_html/) and the Backup Store Path also as default (which is empty). All other settings as default.

I then went to make a backup and got the following error:

“Your backup directory backups is not writeable or does not exists!”

I assumed maybe it needed a folder in the Store path, so created one (755 chmod). But get the same error.

 

Sorry to be a noobie, but what do I have to do to get it to accept the backup path?

 

Thank you for your help.

ps. the Info tab shows everything is OK except the backup path:

Php Configuration Information:
Php Safe_mode: Off 
safe mode will need to be set to Off in order for XCloner to work properly
Php max_execution_time: 3600 
This controls the maximum time your script is allowed to run on server in seconds
Php memory_limit: 64M 
This controls the maximum memory the script may allocate for it's processes
Php open_basedir: no value 
This controls the paths your script is allowed to access, no value means it can access any path
exec() function support: ENABLED 
If this function is disabled, you might want to uncheck Both 'Active' checkboxes from the General Tab
General paths info:  
Temporary Folder /home/londono3/public_html/administrator/backups is writeable 
the path [Backup Start Path/administrator/backups] needs to be created and be writeable in order for XCloner to work properly
Backup Start Path /home/londono3/public_html/ is readable 
the backup start path needs to exist and be readable in order for XCloner to start the backup process
Backup Path: /backups unwriteable 
needs to be writeable in order for XCloner to archive backups
Tar utility server path: /bin/tar 
If the script is unable to determine the tar path automatically, you might need to uncheck the 'Active' checkbox near TAR line in General Tab
Mysqldump utility server path: /usr/bin/mysqldump 
If the script is unable to determine the mysqldump path automatically, you might need to uncheck the 'Active' checkbox near MYSQLDUMP line in General Tabn
November 20, 2010
6:39 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Try and replace your Backup Store Path from inside XCloner Config with value

 

/home/londono3/public_html/administrator/backups 

 

That should fix that error! Regards, Ovidiu

November 20, 2010
10:45 pm
Avatar
Quentin
UK
Member
Members
Forum Posts: 3
Member Since:
November 20, 2010
sp_UserOfflineSmall Offline

Many thanks. All working now Smile

December 25, 2010
7:44 am
Avatar
Guest
Guests

I am having a similar problem:

hp Configuration Information:
Php Safe_mode: Off

safe mode will need to be set to Off in order for XCloner to work properly

Php max_execution_time: 3600

This controls the maximum time your script is allowed to run on server in seconds

Php memory_limit: 64M

This controls the maximum memory the script may allocate for it's processes

Php open_basedir: no value

This controls the paths your script is allowed to access, no value means it can access any path

exec() function support: ENABLED

If this function is disabled, you might want to uncheck Both 'Active' checkboxes from the General Tab

General paths info:
Temporary Folder incorrect or unreadable

the path [Backup Start Path/administrator/backups] needs to be created and be writeable in order for XCloner to work properly

Backup Start Path / is readable

the backup start path needs to exist and be readable in order for XCloner to start the backup process

Backup Path: /home/wildteaq1/public_html/administrator/backups unwriteable

needs to be writeable in order for XCloner to archive backups

Tar utility server path: /bin/tar

If the script is unable to determine the tar path
automatically, you might need to uncheck the 'Active' checkbox near TAR
line in General Tab

Mysqldump utility server path: /usr/bin/mysqldump

If the script is unable to determine the mysqldump path
automatically, you might need to uncheck the 'Active' checkbox near
MYSQLDUMP line in General Tabn

What do I do? Thanks!

 

Quentin said:

Hi, i have just installed Xclone on a 3.1 WP installation. Installed no problem. But I am not sure how to resolve the backup path. I left the default Backup Start Path as is (which ends with: …public_html/) and the Backup Store Path also as default (which is empty). All other settings as default.

I then went to make a backup and got the following error:

“Your backup directory backups is not writeable or does not exists!”

I assumed maybe it needed a folder in the Store path, so created one (755 chmod). But get the same error.

 

Sorry to be a noobie, but what do I have to do to get it to accept the backup path?

 

Thank you for your help.

ps. the Info tab shows everything is OK except the backup path:

Php Configuration Information:
Php Safe_mode: Off 

safe mode will need to be set to Off in order for XCloner to work properly

Php max_execution_time: 3600 

This controls the maximum time your script is allowed to run on server in seconds

Php memory_limit: 64M 

This controls the maximum memory the script may allocate for it's processes

Php open_basedir: no value 

This controls the paths your script is allowed to access, no value means it can access any path

exec() function support: ENABLED 

If this function is disabled, you might want to uncheck Both 'Active' checkboxes from the General Tab

General paths info:  
Temporary Folder /home/londono3/public_html/administrator/backups is writeable 

the path [Backup Start Path/administrator/backups] needs to be created and be writeable in order for XCloner to work properly

Backup Start Path /home/londono3/public_html/ is readable 

the backup start path needs to exist and be readable in order for XCloner to start the backup process

Backup Path: /backups unwriteable 

needs to be writeable in order for XCloner to archive backups

Tar utility server path: /bin/tar 

If the script is unable to determine the tar path automatically, you might need to uncheck the 'Active' checkbox near TAR line in General Tab

Mysqldump utility server path: /usr/bin/mysqldump 

If the script is unable to determine the mysqldump path automatically, you might need to uncheck the 'Active' checkbox near MYSQLDUMP line in General Tabn


December 25, 2010
10:34 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

To fix the above, you need to create this directory /home/wildteaq1/public_html/administrator/backups and make it fully writeable, also setup this folder /home/wildteaq1/public_html/ as your Backup Start Path in XCloner Config.

 

Hope it helps! Ovidiu

December 28, 2010
11:01 am
Avatar
Guest
Guests

I'm having a problem with this same issue. However, I'm trying to create a backup to another server. I've tried putting the correct path in but I keep getting this same error. I've gone into the FTP and am making sure I got all the credentials setup. The problem is that I have no idea what path to put in for a remote server. I want my Wordpress site to backup to my remote server in case that server goes down.

What would the correct path be if I wanted the backup to go to another FTP server? Example, I'm backing up files from

 

/home/username/public_html/DOMAIN1.COM/

 

To a completely different server with a folder called “backup”

 

I tried /home/username/public_html/DOMAIN2.com/backup and CHMOD to 777 and I still get the error that the directory doesn't exist or the location isn't writable.

 

Thanks in advance.

December 28, 2010
12:22 pm
Avatar
Guest
Guests

To make my post easier to understand…how should the remote backup path look like? It's not logical for it to begin with /home

 

The plugin has to connect to the remote site to backup the files….I've got that information in but theres the FTP Path under the credentials. Should this match the backup path. I'm 100% confused here.

 

Thanks in advance.

December 28, 2010
12:29 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Hi Ziah, ok, so i am guessing you have an issue uploading the backup to a new ftp server and not actually creating it?

 

The upload path can be easily verified with a normal ftp client, so simply connect with a ftp client to your remote site and follow the path to your backups folder, that will be your ftp upload path.

 

Any other details you can post here will help in figuring the actual issue, any specific error messages?

 

Ovidiu

December 28, 2010
12:40 pm
Avatar
Guest
Guests

Yeah I created the backup directory on my other server:

 

/public_html/administrator/backups and made sure it's CHMOD 777 and I get:

 

Your backup directory /public_html/administrator/backups is not writeable or does not exists!

 

In Cron tab I have Backup Store Mode set to Remote FTP

 

Ftp server:  servername.net

 

Ftp username:  username

 

Ftp password:  password

 

Ftp path:  /public_html/administrator/backups

 

December 28, 2010
12:41 pm
Avatar
Guest
Guests

Sorry didn't realize I pasted a table in my response. Also I cannot create the backup at all. The second I click on Generate backup I get the error.

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
D: 21
Andy: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9668
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
jose marín
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0