Cron jobs don't work | General Questions and Support | Forum Archive

The free forums are no longer in use. It remains available as read-only archive.

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters – maximum search word length is 84 characters
The forums are currently locked and only available for read only access
sp_TopicIcon
Cron jobs don’t work
June 11, 2014
8:24 am
Avatar
Veronica
Member
Members
Forum Posts: 4
Member Since:
June 11, 2014
sp_UserOfflineSmall Offline

Hi

I've been using XCloner for several years to generate backups and store them on Amazon S3, using wget to run cron jobs. This worked perfectly until I recently upgraded to the latest version of XCloner. I noted that cron jobs now require command-line php, so I SSHed to the server and tested it:

php /home/username/public_html/xcloner/cloner.cron.php myconfig.php

 

This worked, so I copied and pasted the command line to the cron job. When the cron job runs, I get the following message in the emailed cron log:

X-Powered-By: PHP/5.2.9
Content-type: text/html

<h2>Please run this script from a terminal or through a cron scheduler interface</h2>

I am running it via cron. So I don't understand why I'm getting this message. Help!
June 12, 2014
11:53 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Please reinstall XCloner with the latest version from out site and see if it helps, i've just posted an update to it.

 

Ovidiu

June 18, 2014
1:59 am
Avatar
Markus
New Member
Members
Forum Posts: 1
Member Since:
June 17, 2014
sp_UserOfflineSmall Offline

I have “Please run this script from a terminal or through a cron scheduler interface”

When i open the http adress over a Browser.

Can you help me ?

June 18, 2014
5:50 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

XCloner cron access through web interface is not supported anymore due to security concerns. You can either use the cli command along with a proper cron scheduler or use the previous version of xcloner.

 

Ovidiu

June 18, 2014
9:03 am
Avatar
Veronica
Member
Members
Forum Posts: 4
Member Since:
June 11, 2014
sp_UserOfflineSmall Offline

XCloner! Support said:

Please reinstall XCloner with the latest version from out site and see if it helps, i've just posted an update to it.

 

Ovidiu


Have you updated it within the last few days? I'm running v 3.5 which is the version available on the website with a date of February 24. I'm still having the same problem; the cron scripts work fine at the command line but not when run via cron.

June 19, 2014
6:47 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

Yes, we did update it since then.

June 20, 2014
9:53 am
Avatar
Veronica
Member
Members
Forum Posts: 4
Member Since:
June 11, 2014
sp_UserOfflineSmall Offline

I downloaded it from the website again and reinstalled it. I still have the exact same problem.

June 22, 2014
5:41 am
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

If you can open a support ticket and send me the site access details, i'd be happy to look into the issue and fix the problem.

 

Ovidiu

June 23, 2014
2:48 pm
Avatar
Common
Member
Members
Forum Posts: 10
Member Since:
June 23, 2014
sp_UserOfflineSmall Offline

Hello,

**All of this is for Joomla! 1.5.x sites

I am also haing issues setting up my CRON job. I use ICDSoft to host my websites and it has a Cron scheduler on the control panel. I saved a cron config that I want to use to transfer my backups to Dropbox. When I hit execute cron I am met with the following.

***

php /home/beyondthe/www/www/administrator/components/com_xcloner-backupandrestore/cloner.cron.php BackupTransfer.php

To run this script you need to create a custom config file inside XCloner Config, and call the script using php cli command like this:

php /home/beyondthe/www/www/administrator/components/com_xcloner-backupandrestore/cloner.cron.php mycustomconfig.php

***

 

Could you please assit me in setting up a CRON job?

June 23, 2014
8:19 pm
Avatar
Ovidiu Liuta
Admin
Forum Posts: 2484
Member Since:
September 26, 2010
sp_UserOfflineSmall Offline

The cron script needs to be run from the console, browser mode is not supported anymore!

 

Ovidiu

Forum Timezone: America/Chicago
Most Users Ever Online: 867
Currently Online:
Guest(s) 1
Currently Browsing this Page:
1 Guest(s)
Top Posters:
mlguru: 30
Django29: 29
Andy: 21
D: 21
Marcus: 20
Jamie F: 19
Member Stats:
Guest Posters: 737
Members: 9858
Moderators: 2
Admins: 3
Forum Stats:
Groups: 3
Forums: 7
Topics: 2397
Posts: 8236
Newest Members:
Allan Casilao
Moderators: TriP: 0, Steve Burge: 0
Administrators: Ovidiu Liuta: 2484, Victor Drover: 1, Valentin Barbu: 0